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OVERVIEW

About data sources

The MiMI Plugin provides access to data in the MiMI database from within the
Cytoscape bioinformatics network visualization tool. The MiMI database integrates
molecular data from numerous protein-interaction databases, including:

e BIND (Biomolecular Interaction Network Database)
(http://bond.unleashedinformatics.com/)

e CCSB (Center for Cancer Systems Biology)
(http://ccsb.dfci.harvard.edu/web/www/ccsb)

e DIP (Database of Interacting Proteins)
(http://dip.doe-mbi.ucla.edu/dip/Main.cgi)

¢ GRID (General Repository for Interaction Datasets)
(http://www.thebiogrid.org/)

¢ HPRD (Human Protein Reference Database)
(http://www.hprd.org/)

e IntAct
(http://www.ebi.ac.uk/intact/main.xhtml)

¢ KEGG (Kyoto Encyclopedia of Genes and Genomes)
(http://www.genome.jp/kegg/)

¢ MDC (Max Delbriick Center)
(http://www.mdc-berlin.de/en/index.html)

e MINT (Molecular INTeraction database)
(http://mint.bio.uniroma?2.it/mint/Welcome.do)

e PubMed
(http://www.ncbi.nlm.nih.gov/pubmed/)

e Reactome
(http://www.reactome.org/)

Each of these data sources is updated on its own schedule. The MiMI Plugin reflects
updates as they become available.

For information on additional data sources available through the MiMI Plugin, see the
About MiMI page.
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Workflow overview

With the MiMI Plugin for Cytoscape, you can visualize interactions between genes or
proteins, and interactively explore the network of relationships among them. The
basic steps in the workflow include:

1.

Enter a set of genes. You can type in a list of genes or upload a file of gene
symbols.

Select gene and gene interaction attributes. Choose which attributes to display in
a table as you work with a visual network graph, including any attributes you
import into Cytoscape.

Explore the visual network and table of attributes:

e Expand and collapse the network.

e Sort and filter data.

e Visualize your data in a wide variety of network layouts provided by
Cytoscape.

e Use color, size, and other effects to visually reflect a set of attribute values.

Select genes or gene interactions to access more detailed information about
them:

e Link out to additional information about selected objects.

e Access summaries of abstracts mined from the research literature through
natural language processing (BioNLP) related to a selected gene interaction.

e Compare a part of your network to a database of known biological pathways.

Save your session and reopen it later.

INSTALLING CYTOSCAPE AND THE MIMI PLUGIN

You can use the MiMI Plugin for Cytoscape in one of two ways:

By launching Cytoscape and the MiMI Plugin from MiMI Web. With this
method, you launch a temporary copy of Cytoscape and the MiMI Plugin from a
Gene Details page after performing a search on MiMI Web. Use this method when
you don't have the administrative privileges to install software on your computer.
You will not have access to other plugins when you use this method.

By installing Cytoscape and the MiMI Plugin on your local computer. With
this method, you can use other plugins that work with MiMI data, such as
Shortest Path and MCODE.
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Launching Cytoscape and the MiMI Plugin from the Web

To launch Cytoscape and the MiMI Plugin from MiMI Web:

1.
2.

Go to http://mimi.ncibi.org/MimiWeb/main-page.jsp.

On the Free Text Search or List Search tab, search for one or more genes.
(For more information on searching in MiMI Web, click the Help tab.)

On a Search Results page, click a gene link.

On the Gene Details page, click the Cytoscape button near the bottom of the
page.

After launching the Web version of Cytoscape, you can do anything described in this
User Guide.

You can save your Cytoscape session on your local computer and reopen it at a later
time after launching the application from MiMI Web again.

Installing Cytoscape and the MiMI Plugin on your local
computer

1.

Install Cytoscape on your computer. For more information, go to:

e The Cytoscape website at http://cytoscape.org/.

or

e The NCIBI Virtual Workshop page at http://portal.ncibi.org/gateway/virtual-
workshop.html.

After Cytoscape is installed, start the application.

. To install the MiMI Plugin, select Plugins - Manage Plugins from the

Cytoscape menu.
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4. Under Available for Install, click the + box to expand the Network and
Attribute I/0 group.

3 Manage Plugins |
Plugins available For download From
Cytoscape i Cﬁmbnwrioad Site | ]
|| Show outdated Plugins

, Currently Installad: 20

J. Theme: 1

§, Core: 14

|, Network and Attribute IfO: 4

. Uncategorized: 1
Available for Install: 121
#- |, Theme: 1
-}, Analysis:
nication/Scripting: &

( +h , Network and Attribute 1/0: 35
w5 Other: 18

[#- |, Network Inference: 7
[#- |, Functional Enrichment: 13

[

Click to expand the Network
and Attribute 1/O group

dessages:
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5. Find and click the most recent version of the MiMI Plugin.

(] Manage Plugins

S

Flugins available For download From;

Cytoscape

l Change Download Site ]

[] show outdated Flugins

----- - GPML-Flugin v.0.7
----- -f GPML-Plugin v.0.8
----- ~# GPML-Plugin v.0.9
----- -f GPML-Plugin v.1.0
----- -F IntActwsClient v.0.66

----- ~f SessionForWeb v.3.2
----- ~f SFLDLoader v.1.2

----- f SFLDLoader v.1.3

----- -f SkringWsClienk v.1.1

sl SnnErnathwave-Bhinin v 1 0

4| n

m

MiMIplugin i

Version: 3.01

m

Category: Network and Attribute [JO
Description: | &

WLl Cytoscape plugin retrieves molecular
interactions from Michigan MMolecular
Interactions (WEMI) database and displays the
interaction network with Cytoscape. WEMI
gathers and merges data from well-known
protein interaction databases including BIND,
DIF, HPRD, RefSeq, SwissPrat, IPI and

Messages:

[ Install ] [ Close ]

6. Click Install.

7. When installation is complete, click Close.

A MiMI Plugin option is added to the Cytoscape Plugins menu.

ENTERING GENE INFORMATION
1. To begin a Cytoscape session with the MiMI Plugin, start Cytoscape.

2. Select Plugins > MiIMI Plugin > Query from the Cytoscape menu.

3. Choose one of these methods to specify genes.

Option 1: Load a file containing gene symbols

Use when you have a large number of gene symbols. The file:

e Must be a text file.

e Must include a list of official gene symbols, one per line.
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Example:

CE

HFE
SLC35814
FTL
LCNZ

IF
OET1A1
NECZ
B4GALT1
FLD4
3GP11

R Tae]

1. Click the From File tab.

|£| Welcome to MiMI Plugin 3.0.1

| Enter Gene Symbal(s) | From File |

Query MiMI

[ & sampleFile [ Load Gene File...

e

2. Click Load Gene File...
3. Browse to the gene file and click Open.

4. Continue with Additional options.

Option 2: Enter a list of gene symbols

Use to do a query with a small number of gene symbols.

1. On the Enter Gene Symbol(s) tab, enter one or more gene symbols, separated

by commas.

|£| Welcome to MiMI Plugin 3.0.1

oo [ e e |

Enter Gene Symbol(s) | From File|

Query MikI
CP,HFE,SLC39A14, FTL
:Homo sapiens

v: :AII Malecule Types v: :ﬁll Data Sources v:

‘What to retrieve. .. 1 Query genes + nearest neighbors

(Official Gene Symbals: e.g. csFlr,ccnt2)
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Additional options

1. Select an organism, molecule type, and/or data source, or use the defaults.

Note: Selecting All Data Sources includes all of the other data sources listed in

the dropdown, as well as additional data sources. For a complete list of data
sources, see the About MiMI page.

Dialog box after loading a file containing gene symbols:

|£| MiMI Plugin = | B |

Use default parameters or change them

jHomo sapiens vi iAII Molecule Types vi iAII Data Sources vj

What to retrieve. .. 1 Query genes + nearest neighbors

Search

Dialog box after entering a list of gene symbols:

| £| Welcome to MiMI Plugin 3.0.1 =RICIL X

Enter Gene Symbol(s) | From File|
Query MikI

CP,HFE,SLC39A14,FTL (Official Gene Symbals: e.g. csFlr,ccnt2)

'Hama sapiens - | | All Malecule Types « | |Al Data Sources |

‘What to retrieve. .. 1 Query genes + nearest neighbors

.

4

2. For What to retrieve, select one of the following options (examples show

resulting networks for entering a list of the gene symbols CP, HFE, SLC39A14,
and FTL):

Query genes + nearest neighbors

26 nodes, 32 edges
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Interactions among query genes (include at least 2 genes)

O©

2 nodes, 1 edge

Query genes + neighbors’ neighbors

!

4,607 nodes, 28,221 edges

Nearest neighbors shared by more than one query genes (include at least 2
genes)

S-@

2 nodes, 1 edge
3. Click Search.

CHOOSING ATTRIBUTES FOR DISPLAY IN THE DATA
PANEL

Attributes of genes (nodes) and gene interactions (edges) you have selected in the
network appear in the Cytoscape Data Panel.
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Choosing attributes provided through MiMI
To choose which attributes to view:

1. To choose attributes for gene nodes, click the Node Attribute Browser tab in
the Data Panel; for gene interaction edges, click the Edge Attribute Browser
tab.

2. Click the Select Attributes icon in the Data Panel toolbar.

| Data Panel
- D |
(Select Attributes

Node Attribute Browser .. Edge Attribute Browser

3. Select the attributes you want displayed in the Data Panel.

Data Panel

=N
ED 5

| [¥] Component
Description
Function

Gene Name

m

Note: Other plugins used earlier in your Cytoscape session may leave behind
attributes that don’t apply to MiMI Plugin data.

4. When you are done, click anywhere outside the list.
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“Selecting Genes and Gene Interactions”).

Select genes or gene interactions to view their attributes in the Data Panel (see

HAN 1

Data Panel

HOS

Componert

Description

Function

Gene Name

9699

regulating synaptic membrane exocytosis 2

metal ion binding [GO:0046872]; protein binding

RIMS2

50944

cell junction [G0:0030054]; cytoplasm [GO:00...

§H3 and multiple ankyrin repeat domains 1

protein binding [GO:0005515]

SHANK1

5566

cAMP-dependent protein kinase complex [GO

protein kinase, cAMP-dependent, catalytic, alpha

ATP binding [GO:0005524], cAMP-dependent pro.

PREACA

Node Attribute Browser | Edge Attribute Browser | Network Attribute Browser

Importing your own attributes

To add your own attributes to the Data Panel, you can import an attribute file. The
file:

e Must be a text file or a Microsoft Excel 97-2003 workbook file (.xls).
o If a text file:

— Attributes (columns) must be tab-separated.

— Records (rows) must be on their own line.
e Attribute names (column headings) are optional.

e One column must be a key column (for example, Gene Symbol) to map to a key
attribute in the existing network.
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Excel example:

Key column (Optional column headings)

7
A B G i’ E

1 Gene Name p-Value A p-Value B GO term

2 CP 0.038 0.007 iron homeostatis Heme metabolism
3 |HFE 0.011 0.001 iron homeostatis Heme metabaolism
4 SLC39A14 0.17 0.06 iron homeostatis Heme metabolism
5 |FTL 0.302 0.007 iron homeostatis Heme metabolism
6 [LCN2 0.55 0.08 iron homeostatis Heme metabaolism
T (TF 06 0.06 iron homeostatis Heme metabaolism
8 UGT1A1 0.001 0.0004 iron homeostatis Heme metabaolism
9 |NPC2 0.34 0.008 Cholesterol Homeostatis

10 B4GALT1 0.28 0.003 Sphingolipid Metabolism

11 |PLD4 0.38 0.0001 Sphingolipid Metabolism

12 | SGP11 0.044 0.009 Sphingolipid Metabolism

13 EDG3 0.016 0.0005 Sphingolipid Metabolism

14 SOATH 0.37 0.0006 Cholesterol Homeostatis

15 ABCA1 0.008 0.004 Cholesterol Homeostatis

16 APOD 0.002 0.001 Cholesterol Homeostatis

For information on other importing options, see “Import Attribute Table Files” in the
Cytoscape User Manual.

To import attributes:

1. From the Cytoscape menu, select File > Import 2> Attribute from Table
(Text/MS Excel)...
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2. For Attributes, select Node, Edge, or Network, depending on the attributes
you're adding, and click Select File(s).

raimpon.;lnnotation-f-il_e p ~ g
Select the attribute type)

¢ N
@ Import Attribute able
— (hen click Selec@*

Data Sources
Attributes @ Node Edge MNetwork

Input File [ Select Fies) |

Advanced
[ Show Mapping Options || Show Text File Import Options [| Import everything (Key is always ID) [V] Case Sensitive

Preview
Left Click: Enable/Disable Column, Right Click: Edit Column Legend: IETH 0
[ Data File Preview Window Key Attributes
10117 -
10200
@ 10381
= o 10382
T— i/ 10577
e 10672
D ‘ B 10720
. 1356 =
File Size: Unknown Import | cancel

3. Browse to your attribute file, and click Open. Attribute data is imported:

(o] Import Annotation File l&f
O
Import Attribute from Table
Data Sources

Attributes @ Node (7) Edge () Network

Input File file:/C: [Users| |Desktop/CytoiHemeAndSphingMoHdgReadInList. xls

Advanced

|| Show Mapping Options [ Show Text File Import Options [] Impart everything (Key is always ID) Case Sensitive

Preview
Excel™ Workbook Left Click: Enable/Disable Column, Right Click: Edit Column Legend: [JEET IEEEH
m‘ Key Attributes
10117 il
¥ Column 1 ¥ Column2 + Column3 + Column4 v 10200 =
Gene Name p-Value A p-Value B GO term - 10381
CP 0.038 0.0070 iron homeostatis 3 10382
HFE 0.011 0.0010 iron homeostatis |; 10577
SLC39A14 0.17 0.06 iron homeostatis
FTL 0.302 0.0070 iron homeostatis 10672
LCN2 0.55 0.08 iron homeostatis 10720
TF 06 0.06 iron homeostatis
ar o 1356

Key Matched: 0

First 100 entries are loaded for preview.

File Size: 17 KBytes
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4. If your attribute file includes attribute names as column headings, select Show

Text File Import Options, and then select Transfer first line as attribute
names.

(Select Import Options)

Advanced /

Show Mapping Options [J] Show Text File Import Options

Import everything (Key is always ID)
Text File Import Options

Delimitar Praview Options

Show all entries in the Fi
Attribute Names Net
[7] Transfer first line as attribute names Start Import Row: | -~ Comment Line: -

Deevica Select Transfer option)

@ Excel™ Workbook Left Click: Enable/Disable Column, Right Click: E
Sheet1

.V Gene Nam

* p-ValueA </ p-ValueB <« GOterm

CP iron homeostatit
HFE

0. ) / iron homeostatit
SLC39A14 0.17 \ 0.06 / iron homeostatit

(First-row values become attribute names)

038 | 0.0070
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If your attribute file does not include column headings for attribute names, name

them by right-clicking the default column headings and entering a new attribute
name.

............................. 13

(Right-glick default column headina)

Preview

Q| Excel™ Workbo eft Click: Enable/Disable Column, Right Click: Edit Column L
£ Set Attribute Name and Type

[ sheet1 |

— 1

Then enter a new attribute name

o Column 1 o2 Attribute Name and Type

CP | Attribute name For Column 1
HFE |

Column 1
SLC39A14 | |
FTL Attribute Data Type
LCN2 | 8 @) String () Inkeger () Floating Point (7) Boolean
TF - ek g ~F Chrinnc
UGT1A1 1 3 Lﬁt‘ LIS O ring -
il 4 List Delimiter is: @

Key Matched: 0 1 | Other

5. To map your key column to the key attribute, first click Show Mapping
Options, and then select the column from the Primary Key dropdown.

Show mapping options

Select a key column

Key Column in Annotation File / Key Attribute for Network
Primary Key: ah Gene Name

-
B D -

)vs ID) (V] Case Sensitive

Alas? Column (Attribute Name) Data Type

| [ |Gene Name | dpstring | .
] lpValue A | Foat |z

L |p-val 83 !

[ & p-Value B 5 Float |

Cotem (Selected key column attribute is highlighted)
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6. Select the corresponding key attribute in the existing network.

Advanced
[¥] Show Mapping Options [] Show Text Fil Import R R . . .
Select the matching key attribute in the existing network
= jon File to R
Key Column in Annotation File Key Attribi§e for Network
Primary Key: (3 Gane Name ]
|Alias?  Column (Attribute Name) Data Type Q ) \ =l
| - A Locustag -
[l |Gene Name dp string | . 3y Pathway
..... p-Value A | 25 Float = ap C i
p-Value B % Float T g
GO term | h String i | b Gene type

m

l

m Excel™ Workbook Left Click: Enable/Disable Column, Right Cl3p Map_loc

7. Click Import at the bottom of the dialog box.

8. To view your attributes in the Data Panel, click the Select Attributes icon in the
Data Panel toolbar and select the attributes, which will appear in the panel when
you select nodes and edges that have imported attributes associated with them.

e

Imported attributes €
are displayed when

matching nodes are
selected

A ¥ N |
Ly

N

Data Panel \ \
M0 @ YN\,
D Gene Name p-Value A pVaed | GO term | Component

54658 | UGT1A1 0.0010 4.0E-4 iron homeostatis _ | endoplasmic reticulum [G0:000
10577 NPC2 0.34 0.0080 Cholesterol Homeostatis extracellular region [GO:000557
3984 LIMK1 | | eytoplasm [GO:0005737]; facal
3077 HFE 0.011 0.0010 iran homeostatis cytoplasm [GO:00057 37]; integr
79947 DHDDS
2512 | FiL 0.302 0.0070 | iron hameostatis | ferritin complex [G0:0008043]
6927 | HNFIA , | nucleus [60:0005634]; protein
7037 TFRC cytoplasmic membrane-bound.
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Rearranging attributes in the Data Panel

To reorder attributes in the Data Panel, click an attribute column heading and
drag it to a new location.

Data Panel
— T
D

Component Gene Nam
9543 integral to membrane [GO:0016021]; membrane [G... | PUNC
8029 brush border membrane [GO:0031526); endosome... | CUBN
7786 cytoplasm [GO:0005737]; cytosol [GO:0005829]; m... | MAP3K12
7036 cytoplasm [GO:0005737]; integral to plasma memb... | TFR2
7018 endocytic vesicle [G0:0030134); endosome [G0:00... | TF

6872 nucleus [GO:0005634]; transcription factor TFID co... | TAF1
5764 endoplasmic reticulum [GO:0005783]; extracellular . | PTN
567 exir i JL005576); MHC class | prot... | B2M

Data Panel

M0

Drag the column

Componer Gene Name i~ l«—

9543 integral to membrane [GO:00| PUNC lae[G..
8029 | brush border membrane [GO] CUBN lome...
7786 cytoplasm [GO:0005737]; eytd MAP3K12 II; m...
7036 cytoplasm [GO:0005737]; intg TFR2 lemb...
7018 endocytic vesicle [GO:003013 TF 0:00...
6872 nucleus [G0:0005634); transq TAF1 Dco..
5764 endoplasmic reticulum [GO:0| PTN Iulal...
567 extracellular

Drop the column into position

Data Panel

M0

Gene Name H

9543 | PUNC r__ntegral to membrane [GO:0016021); membrane [G...
8029 | CUBN W' rush border membrane [GO:0031526]; endosome...
7786 MAP3K12 ytoplasm [GO:00057 37); cytosol [GO:0005829]; m...

7036 [TFR2 [toplasm [G0:0005737]; integral to plasma memb...
7018 TF indocytic vesicle [GO:0030139); endosome [GO:00...
6872 | TAF1 Jucleus [GO:0005634J; transcription factor TFIID co...
5764 PTN indoplasmic reticulum [GO:0005783]; extracellular ...
567 | B2M pracellular region [GO:0005576), MHC class | prot...

To sort by an attribute, click the attribute column heading; to sort in the reverse
direction, click again.

Data Panel
F O
hi

1D Gene Name % Component
19 ABCA1 L& integral to plasma membrane [GO:00045
335 APOA1 cytoplasmic vesicle [GO:0031410]; endc
336 ARPOAZ chylomicron [GO:0042627]; extracellular
347 ARPCD extracellular region [GO:0005576]; extra
9326 ARHGEF11 cytoplasm [GO:0005737]; intracellular [C
23365 ARHGEF12 cytoplasm [GO:0006737]; intracellular [C
538 ATPTA basolateral plasma membrane [GO:001
567 B2M extracellular region [GO:0005576]; MHC
Mode Aktribute Browser | Edge Atkribuke Browser | Metwork Attribute Elrcnwser|
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NAVIGATING A NETWORK

Navigating among networks

To navigate among multiple open networks, use the Network tab in the Cytoscape
Control Panel.

( Total number of nodes/edges )

Control Panel (&
T8 Metwork | vizMapper™ [Editor Fiters]l‘-'i Ril

: Edges
- Current network
Network with no H105(5) 176(0)
network window -

1761(0)
110(0)
30(0)
1468(336)

LR N N

(Number of selected nodesledges)

To view a network, click on its entry on the Network tab.

Note: The default network title is a list of the queried genes followed by the options
you selected for the query. To edit a title, right-click the network entry and select
Edit Network Title.

For more information about working with networks and the Network tab, see the
Cytoscape User Manual.
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Navigating within a network

To navigate within a network, use the network overview pane at the bottom of the
Network tab in the Cytoscape Control Panel.

Fle B8t View St Lnyout Phgier Help

=1 = Hc¥oRegodic ey = - 18

Cormal Passl [P HFE SLCIRATA Fama 1apien il Mealecule TymedjAl Doty Sowcea|L Query gents « neseit neighbari] e

Area visible in
main network
window

OHATS
BRHGEFIT |

Crtsscape 26.3 Rught-caei: = drg e 200M [

To view another part of the network, click on the shaded area in the network
overview pane and drag it into place.

To adjust the view magnification, use the Zoom tools in the Cytoscape toolbar:

Q Q

and Zoom In

e Zoom Selected Region Q . Make one or more selections using any Cytoscape
methods, then click this tool to display the region that encompasses all of them.

@

e Zoom Entire Network .

e Zoom Out

For more information about zooming and using the network overview pane, see the
Cytoscape User Manual.
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Locating genes or gene interactions within a network by
searching

You can locate and select a specific gene or gene interaction within a network by
using the Search feature of Cytoscape. You can also use search to find a group of
genes or interactions with common attribute values. Search is especially useful with
large, complex networks.

Limitations of the Search feature in Cytoscape:

e For a successful match, the search term must match the entire attribute value.
For example, the following Gene Description attributes do not match:

— NADH dehydrogenase (ubiquinone) 1 beta subcomplex, 8, 19kDa
— NADH dehydrogenase (ubiquinone) 1 beta subcomplex, 2, 8kDa

e For a successful match, the search term must match the attribute value from the
start of the string—you cannot match a substring within an attribute value. For
example, the search term Lysine biosynthesis does not match the following
attribute value:

— Citrate cycle (TCA cycle) [path:hsa00020]; Lysine biosynthesis
[path:hsa00300]; D-Glutamine and D-glutamate metabolism
[path:hsa00471]

e Search does not support logical operators, wildcards, or other advanced search
features.

Note: For more flexible and powerful searching, including logical operators and
wildcards, you can use the Enhanced Search plugin for Cytoscape. For more
information, see the Analysis group of plugins on the Cytoscape Plugins page.

To search for genes or interactions:

1. Click (Configure search options) to the right of the Search box in the
Cytoscape toolbar.
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2. Set search options.

| 4 Configure Search Options for: FZP1 AFAM1 CF M..jH... SES

Search: |

® Nodes () Edges 4—(Select which attributes to IisD

Select Attribute:

Gene Name 4 Select the attribute

.Chn:um-:m-:um-: -
Component to search by

Description =

Function
G0 term /

Gene type
Kegg gene -
Sample Attribute Valuss:

PREF
RXFP4 Click Appl
SERPING1 ( i
VT

TE2

Cancel ' . Apply

.

3. Enter a search term in the Search box. As you type, matching attribute values
appear in a dropdown list.

FZP1 AFdkImag
maspl

Data Sources|l. Query genes + nearest neighbors|

-

mepla

myoc
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4. Select an item in the list to locate the node or edge. Cytoscape zooms to the item
and selects it.

Note: Using Search to select a gene interaction also selects the connected genes.

Search: |masp1| |"‘

FZP1 AFAML CF M...|Homo sapiens|&ll Maolecule Types|&ll Data Sources|l. Query genes + nearest neighbors|

Example: Locating genes on the same chromosome (chromosome 13)

1. In the Configure Search Options dialog, select the Chromosome attribute for
genes (nodes).

(4] Configure Search Options for: FZPL AFAM1 CF M..[H... SEESE

Search:
(@) Modes (7) Edges

Select Attribute:

Chromosome R

Attribute Description:

No description available.

Sample Attribute Values:
1

]

17

16

11
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2. Type in the Search box and select 13 (with 6 matching genes).

search: (41| |v‘ |

FZP1 AFAlL 24 nies || Pata Sources|l. Query genes + nearest neighbors|
10 7 hits

11 20 hits
12 12 hits
13

& hits

g

3. The 6 genes are selected.

Search: (13 |"‘

FZP1 AFAML CF M. |Homo sapiens|&ll Molecule Types|&ll Data Sources|l. Query genes + nearest neighbors|

-

4. The Data Panel displays attributes for the selected genes.

Data Panel
0@

ID Chromosome izene Mame Componenk
8423 13 STH24 cytoplasm [GO:.0005737]
8303 13 SUCLAZ mitochondrion [GO:00057 349]
1045 13 CDx2 condensed nuclear chromosome
1282 13 COoL4Al bhasement membrane [GO:0005¢
10562 13 QLFm4 extracellular region [GO:0005576
1284 13 COL4AZ collagen [GO:0005531]; collagen
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Locating genes or interactions using the Data Panel

You can locate specific gene nodes and interaction edges in the network view by
selecting their attributes in the Data Panel.

1. Click the Node Attribute Browser or Edge Attribute Browser tab in the Data
Panel.

2. Select attribute rows for the nodes or edges you want to locate.
e Click on a single row to highlight a single gene or interaction.
e Use Ctrl-click to select multiple discontiguous rows.
e Use Shift-click to select a range of contiguous rows.

3. The corresponding genes or interactions are highlighted in green in the network
view.

——t
Data Panel
M O
|

D Gene Mame Camponent
25 ABL1 cellular_compaonent [GO:00055758]; cytoplasm [GO:...
58 ACTAT actin filament [GO:0005224]; cytoplasm [GO:00057 ...
594 BCKDHB mitochondrial alpha-ketoglutarate dehydrogenase ..
730 cy extracellular region [GO:000557 6], membrane attac...
930 cD18 integral to plasma membrane [GO:.0005887]; plas...
13738 CR1 integral to plasma membrane [GO:0005887]; mem...
1380 CR2 integral to membrane [GO:0016021]; plasma mem...
8519 IFITh1 integral to membrane [GO:0016021]; plasma mem...

< |

Maode Attribute Erowser | Edge Attribute Browser | Metwork Attribute Ernwser|
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Note: This procedure helps you visually identify individual nodes or edges from
among those already selected in the network view, but does not create an actionable
subset. Cytoscape functions will continue to operate on all selected nodes or edges,
not just those you have located using this procedure.

SELECTING GENES AND GENE INTERACTIONS

Use Cytoscape methods to select nodes (representing genes) and edges
(representing interactions between genes).

Selecting a single gene

Click the gene node.

A selected node appears in yellow.

Selecting a single gene interaction

Click and drag a rectangle around any
segment of the gene interaction edge,
then release the left mouse button.

A selected edge appears in red.
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Selecting multiple genes and/or
gene interaction edges

Hold down the Shift key while clicking on
nodes and/or edges and/or while
dragging rectangles around them.

Selecting genes and gene
interactions within an area

Click and drag a rectangle around any
area of the network to select the nodes
and edges within that area.

Selecting any part of a node or edge
selects the entire node or edge.
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For more information

For detailed information on selecting nodes and edges in a network, see the
Cytoscape User Manual.

ACCESSING GENE AND GENE INTERACTION
INFORMATION

In addition to viewing gene and gene interaction attribute values in the Cytoscape
Data Panel, you can link to related information in additional data sources.

Linking to gene literature through Gene2MeSH

To access PubMed articles related to a gene through matching MeSH subject
headings:

1. Right-click a gene node, and select MiMI Plugin - LinkOut NCIBI >
Gene2Mesh.

2. The Gene2MeSH page for the selected gene appears in a new browser window or
tab

Search Gene2MeSH About Gene2MeSH

HFE Saarch by: @ Gene @ MasH Term @ Both Limit Search by Organism: [GEIRCETEIENS

Gen=2MeSH Search examples: brea2, "Prostatic Neoplasms ™

-
history © : HFE (109)

NCiBI

108 MeSH headings found matching gene symbol "HFE"

I bl
B = lookup gene or MeSH heading at NCBL: | = view interactions in MiMI show All Columns (] | dounioad tab-dalimitad rasults

TaxID P-Value

5

HFE'® M Hemochromatosis § 9606 o genetics hemochromatasis 29

[
&
o

= 9606 o genetics hemochromatosis

HEE® M

i
o
N

HFE'® M Membrane Proteins § 9606 o genetics hemochromatosis.

oo

HFEE'® M Lron @ 9608 3.8973051127583E-281 metabelism hemochromatesis
TP ,’.._..-u-a- il e ‘M"'_'_m A, e o PR S P A

For more information about using Gene2MeSH, see the Gene2MeSH About page.

Linking to detailed information on MiMI Web
To access more detailed information about a gene or gene interaction:

1. Right-click a gene node or gene interaction edge, and select MiMI Plugin >
LinkOut NCIBI > MiMIWeb.

2. The Details page in MiMI Web for the selected gene or interaction appears in a
new browser window or tab.
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For a gene:

Free Text Search Query Int
Download as PSI-MI

@ Gene Details

Sy
T Molecule Details for Gene Entry HFE (Geneld: 3077) - show/hide

hemochromatosis Gene Attributes
HFE(Homo sapiens) Cellular Components...
G Ty Rt ting MHC class I protein complex
g cytoplasm

Chromosome: &
Map Locus: 6p21.3
Locus Tag: null

integral to plasma membrane
membrane
plasma membrane

.
.
.
.

Other Names...

» HFE
« d1221C16.10.1
» HFEL

» HH

» HLA-H

* MGC103730

Descriptions...

#» Authorized Gene Description:
hemochromatosis
» Other descriptions...
o MHC class I-like protein HFE
o hemochromatosis protein
o hereditary hemochromatosis protein
HLA-H

%\\-I’ Protein Interactions (3 gene interactions found) - show /hide

immune response
ion transport

iron ion transport

protein complesx assembly

-
-

receptor-medisted endocytosis z
P

Biological Processes...

antigen processing and presentatio
antigen processing and presentatio
of peptide antigen via MHC class 1
cellular iron ion homeostasis

Literature Mined Interactions (6 Interactions found) - show /hide

1

2 e
<’ Literature on gene HFE (584 publications found) - show /hide

g
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For an interaction:

MICHIGAN MOLECULAR INTERACTIONS

Free Text Search List Search Query Interactions About MIMI

Interacti_qn Details

T
T Genes

FE -- B2

& Pathways - show /hide

GO o Terms - show /hide

W Protein Interaction Types And Annotations - show /hide

é Provenance Sources - show/hide

L L PR VR WY PP VY PYY W 5

X Literature associating interactions - show /hide

National Institutes ofHealth grant #U54 DA021519.
NCiBI & )

Urarsy o ekegan Copyright 2008 by The University of Michigan ‘

www.necibi.org - For support and questions email: mimi-help@umich.edu

{

-

For more information on using MiMI Web, see the MiMI Help and Support page.

Linking to gene interaction literature through BioNLP

To access summaries of abstracts related to a gene interaction through BioNLP
(Natural Language Processing of Biology text):

1. Right-click a gene interaction edge, and select MiMI Plugin - BioNLP.
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2. A list of matching sentences appears.

( Click to view the Gene Details page on MiMI Web )

|#| Cytoscape MiMI Plugin Query BioNLP

25 Sentences Related To And [B2M] From BioNLP

m

ty [May take several minutes for long lists] Computed by MEAD , a

SORT (sGLE ¢LICK) Sentences by semantic
1 ed extractive summarization system

Stable, recombinant, water-soluble complexes of HLA-A2 and HLA-B27 were reconstituted
1517560 ABSTRACT HFE B2M  from 125I-labeled beta 2-microglobulin (beta 2m), a synthetic peptide, and HLA H chain
fragments expressed as inclusion bodies in the Escherichia coli cytoplasm.

This effect was attributed to a more efficient association of HLA H chains with human than
B2M  with murine beta 2-microglobulin, which apparently allowed a more rapid transport of the
HLA molecules from the endoplasmic reticulum to the Golgi apparatus.

Previously, hepatic iron overload resembling that in hereditary hemachromatosis (HH) has
been found in beta 2-microglobulin knockout (beta 2m-/-) mice

2456352

8020884 B2M

9234244 ABSTRACT B2M  HLA-H associates with beta-2-microglobulin

MATFRTALS AND METHODS: We have semuenced the cnding recion and narts nf introns nf = 7
’

4

N

AN
G:Iick to view the PubMed abstract of an articI(D

Linking to other data sources

You can access gene and gene interaction information from numerous external data
sources using LinkOut menus in Cytoscape.

Linking to external sources from the network view

1. In the Cytoscape network view, right-click a gene node or interaction edge.
2. Move to the LinkOut menu.

3. Choose a data source from the LinkOut submenus.
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For example, selecting LinkOut > Entrez > Gene:

3077
Visual Mapping Bypass #
5E b Se ]

MiML Plugin b/ Reactome 4
MetScape »|  Model Organism DE ¥
Array Express 4
Ensembl Gene View P
KEGG »
All Databases (Global search by free keyword)
Interaction Databases | Structure
iHOP ¢ Pubmed
Other Biological DB rP
Ontology ¥ Protein
EBI Tools ko OMIM
UniProt b Mucleotide
Search Engines 4 i

results in the following Entrez Gene page for the selected gene:

¥
s IPE—
=B\l Entrez Gene ¢
All Databases PubMed Nucleotide Protein Genome Structure OMIM
Search Gene - for 3077[uid] Go Clea

| Limits | Preview/index | History | Clipboard | Details |

Display  Full Report = Sendto -

[C] 1: HFE hemochromatosis [ Homo sapiens ]
GenelD: 3077
Summary

Official Symbol HFE
Official Full N\ame hemochromatosis

Primary source HGNC:4886
See related Ensembl:ENSG00000010704; HPRD:01993; MIM: 235200
Gene type protein coding
RefSeq status REVIEWED
Organism Homo s3piens
A P I S A AR LS WL i AL R SRR L
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Note: The external data sources available for genes differ from those available for
gene interactions.

Linking to external sources from the Data Panel

When linking to external data sources from the Cytoscape Data Panel, you can link to
the external source using a specific attribute value. However, not all attribute values
are appropriate for all data sources.

1. In the Cytoscape Data Panel, right-click on the value in the attribute column in
the row for the gene or interaction of interest.

Data Panel
ID Gene Mame Kegg gene Componenk
3934 LIMEA hsa: 3934 cytoplasm [GO:000587 37]; focal
J175 OMECUTH hga:3175 nucleus [GO.0005634]
6927 HMF1A hsa:6927 nucleus [GO:0005634]; protein
10720 LIGT2B11 hsa 10720 endoplasmic reticulum [GO:00C
3077 HFE hga:3077 Select f 3 bI Caza r
7037 | TFRC hsa.7037 HEIECLRSInL |
Copy
Select All
Export... L
Search hsa:3077 on the web #

2. Move to the Search...on the web menu, and choose an appropriate data source
from the submenus.

Ensembl Gene View F
LEE FEE EBI Tools 3
E D UniProt 4
j(5] Gene Name Kegg gene Companen Model Organism DB » Function
39384 LIME1 hsa:3984 cytoplasm [GO:0005737], focs  Entrez ¥ [P binding [GC:0005524]; metal
F175 OMECUT hsa:3175 nucleus [GO:0005634] Array Express » quence-specific DMA binding [C
6927 HMF 1A hsa:6327 nucleus [GO:0005634]; protei ; : otein hinding [GO:0005515]; seq
10720 UGT2B11 hsa: 10720 endoplasmic reticulum [Go:0  OtherBiological DB ¥ {0\ ronosyitransferase activity [C
3077 HFE hga:3077 R Tl ; iHOP } onion binding [G0:0005506]
7037 TFRC hsa:7037 r Y yeast (use ORF name)
apy T m
Interaction Databases » AR EECAECR AT
Select All
Reactome ] mouse (use NCEI GenelD)
Export... ]
Ontology ] human {use NCBI GenelD}
SRR sohengine: >
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For example, right-clicking the value hsa:3077 in the Kegg gene attribute column
and selecting KEGG > All Species (use KEGG ID) results in the following KEGG
page for the corresponding gene:

K[ Homo sapiens (human): 3077

Entry 3077 CDS H.sapiens

Gene name |HFE

Definition|hemochromatosis

Disease H00211 Hemochromatosis (HFE)
Class |BRITE hierarchy)
SSDB \Ortholog) | Paralog J | Gene cluster ) ( GFIT )
Motif Pfam: MHC I Cl-set DUF312 Peptidase C5
PROSITE: IG MHC IG LIFE
i Motif J

Other DB= |NCBI-GI: 4504377
NCBI-GeneID: 3077

OMIM: 233200

HGHC: 48EB6

HPRD: 018983

Ensembl: ENSG00000010704
UniProt: BZCELO 30201

AT N L LTV OrW W L Y T R WL Y P VY W

LinkDB | All DBs |
Structure |PDB: lacZ 1DE4
Thumbnails ) %i‘?ﬁ'
o
. Jmol J
Position |ep2l.3
AR seq 348 aa (AA seq | ( DB search)

MGFRARFALLLLMLLOTAVLOGRLLESHS LHY LFMGASEQDLGLSLFEALGY VDD
YDHESERVEPRTEFWVS5RI 5 5OMWLO LSS LEGWDHMFTVDFWT IMENANHSEE

| g g O D ST G Y G D Qi L C BT L DR AR PRAE T L EER K

V-

N

MATCHING PATHWAY GRAPHS USING SAGA

Use SAGA (Substructure Index-based Approximate Graph Alignment) with the MiMI
Plugin to compare and match selected nodes and edges to a database of known
biological pathways.
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1.

Select a subset of a MiMI network in Cytoscape, with the following requirements:
e Select at least 2, but no more than 50, gene nodes.

e Select at least 1, but no more than 80, gene interaction edges.

\ CTAT)

IND,

"
/3
N
Right-click any selected node and select MiMI Plugin > SAGA > Do SAGA
(Choose multiple nodes & edges).

| £| MiMI Plugin RS

Query SAGA

.:}CEGG Human Pathwaysi - Percentage of Maktched Modes: 10,0 7% [ Query ] [ Cancel ]

Select either KEGG Human Pathways or All KEGG Pathways.

For Percentage of Matched Nodes, specify the percentage of selected nodes
that must match a known biological pathway for the subset of nodes to be
considered a successful match with the pathway. The default is 10%.
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5. Click Query. The results appear in a new browser window or tab.

The Query Result:

Result for the Query: MiMIPlugin2SAGA

Total Execution Time (s): 0.030983
Number of Matches: 4 (excluding self matches)

Matches Overview:

Match No. Match Graph Name (#Nodes, #Edges) Graph Distance  Matching Nodes
Match £1 pattrhsa04610 (50.67) [Complement and coagulation cascades]  21.00 3 out of 8
Match #2 pathchsa04620 (62,79) [Toll-like receptor signaling pathway] 24.00 2 outof 8
Match #3 pathrhsa04012 (53.85) [ErbB signaling pathway] 25.00 2 out of 8
Match #4 pathhsa04630 (22,27) [Jak-STAT signaling pathway] 25.00 2 out of §

6. Click a link in the Match No. column to view a visual representation of the match
between selected network nodes in your query and the matching graph.

[Go Back to Matches Overview]

Match #1: path:hsa04610 (50 nodes, 67 edges) [Complement and coagulation cascades]

Graph Distance 21.00 (3 out of § nodes match)

[Link to KEGG Picture] (with the matching nodes highlighted)

Blue rectangles indicate
matching genes

query: MiMIPlugin2SAGA

Thick blue lines indicate AT

L . c2
matching interactions

\/ BB graph: path:hsa04610
ifnar2 ndufb6 c3 [C4A...IC2I]
stat2 prkeb - c5 [C3ICFB,_BFD, BHI]
/ / ( Matching gene in )

Matching query gene in E overlapping pathway
Cyt<|>scapelMiMI network cpnl cs 4’/

(Thin red line connects matching genes)

7. To view the complete KEGG pathway that was matched, click the [Link to KEGG
Picture] link.
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WORKING WITH NETWORKS

Expanding a network on a gene node

You can expand the current network to the nearest neighbors of a gene node.

Original network:

1. Double-click a gene node (the expansion seed).

2. If the number of additional gene nodes exceeds 30, Cytoscape displays the
number and asks if you want to continue. Click Yes or No.

3. If expansion continues:
e The network expands, adding the nearest neighbors of the expansion seed.

e The network view may be redrawn, and the expansion seed may appear in a
different location.

¢ On the Network tab in the Control Panel, the number of nodes and edges is
updated.
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Expanded network:

Symbols appearing in a network expansion:

Expansion seed node (selected)

GA

I\

4

Expansion seed node
(unselected)

GA

I\

v’

Expansion neighbor (selected)

Expansion neighbor (unselected)
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Collapsing an expanded gene node

To collapse an expanded gene node, double-click the expansion seed. The network
returns to its original state.

Note: For best results, if you have further expanded a network by expanding on an
expansion neighbor, collapse the nodes in the reverse order in which you expanded
them.

Destroying a network

To destroy a network you no longer need:

1.

Make sure you want to destroy the network:
e Cytoscape will not ask you to confirm the deletion.
e Destroying the network is irreversible.

¢ Note: If you want to destroy a network view without destroying the network
itself, use Destroy View instead of Destroy Network. See the Cytoscape
User Manual for more information.

On the Network tab in the Control Panel, right-click on the network you want to
destroy (the network does not need to be selected), and select Destroy
Network.

SAVING AND REOPENING A SESSION

Saving a session

To save a Cytoscape session containing one or more MiMI Plugin networks:

1.

2
3.
4

From the Cytoscape menu, select File > Save (or Save As...).
Browse to a location for the session file.
Name the file.

Click Save.

Reopening a session

To reopen a saved session containing MiMI Plugin data:

1.
2.
3.

From the Cytoscape menu, select File > Open.
Navigate to the file location.

Select the file.
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4. Click Open.

5. After Cytoscape reports that the session file was successfully loaded, click Close.

USING MIMI PLUGIN-SPECIFIC FEATURES IN
CYTOSCAPE

Restoring the MiIiMI visual style

You may need to restore the MiMI visual style after using a different plugin that uses
its own style.

Network after using the MCODE plugin with MCODE visual style

1. In the Cytoscape Control Panel, click the VizMapper™ tab. You may need to use
the scroll arrows 4| *| at the top of the Control Panel to see the tab.

2. For Current Visual Style, select MiMI:

Caontrol Panel

bwork | VizMapper™ | Editor | Filkers | mi
Current Visual Style

MIMI v
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3. The MiMI visual style is restored:

Network after resetting the MiMI visual style

Annotations

You can add public or private annotations to a gene node or gene interaction edge.
For more information:

e See Adding your own node/edge annotation in the MiMI Plugin tutorial on the
NCIBI website.

e Explore on your own by right-clicking a node or edge and selecting MiMI Plugin
- User Annotation > Add Your Annotation. (You will need to sign up and
then sign in to create your own annotations.)
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Accessing the MiMI Plugin legend

In the Cytoscape Control Panel, click the MiMI Legend tab. You may need to use
the scroll arrows *1*/ at the top of the Control Panel to see the tab.

vizMapper™ | Editor | Fiers | MMI Legend ]
O Initial seed node
O‘ Meighboring node
A Expansion seed
O Expansion neighbor
User annotation
—  Mormal Interaction
User annotation

Note: If you open a saved Cytoscape session, the MiMI Legend tab does not
appear in the Control Panel until you use the MiMI Plugin to enter gene information
in a new query.
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MiMI Plugin selection behavior

When you select nodes and edges, they are highlighted in the network view, and the
attributes of the selected nodes or edges are displayed on the Node Attribute
Browser or Edge Attribute Browser tab in the Cytoscape Data Panel:

(Selected edge)

‘ Selected node

Data Panel
Gene Mamea 1D i Description | Gene type ! Kecg
| APOAT 1335 | apalipoprotein A-| | protein-coding | hsa:
OMECUT1 3175 | one cut homeobox 1 / 1 protein-coding hsa:

UGT1A1 54658 UDP glucuronosyl ferase 1 family, polypeptide ... | protein-coding hsa:
|UGT1A3 54659 | UDP glucuro transferase 1 family, polypeptide ... | protein-coding | hsa:

( Attributes of selected nodes )

+ Attribute Browser | Network Attribute Browser|
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